Was sind die Anforderungen, um Joomla! 1.5 zu betreiben?

Joomla! läuft auf PHP-Basis. PHP gibt es in verschiedenen Ausprägungen und für viele Betriebssysteme. Neben PHP benötigen Sie noch einen Webserver. Joomla! ist für Apache optimiert, aber es läuft auch auf anderen Webservern, wie Microsoft IIS. Joomla! ist zudem datenbankbasiert und dafür steht im Moment nur MySQL zur Verfügung. Viele Leute wissen aus eigener Erfahrung, […]

MEHR ERFAHREN

Wo sind die Installer hin?

Das verbesserte Installationswerkzeug befindet sich im Menü „Erweiterungen“. Vor Joomla! 1.5 musste der jeweilige Erweiterungstyp zunächst ausgewählt werden, bevor die Installation durchgeführt werden konnte. Mit Joomla! 1.5 wählen Sie nur noch die Erweiterung aus, die Sie hochladen möchten, und klicken auf „Installieren“. Das Installationswerkzeug macht dann für Sie den ganzen Rest.

MEHR ERFAHREN

Kann man den Typ eines Menüeintrags ändern?

Ja, die Anzeige der verschiedenen Menüeintrags-Typen können Sie ganz beliebig anpassen, auch nachdem Sie einen Menüeintrag erstellt haben. Wenn Sie zum Beispiel den Blog-Bereich eines Menü-Links ändern wollen, gehen Sie in die Administration und bearbeiten den Menüeintrag. Klicken Sie auf „Typ ändern“ und verändern Sie die Einstellungen für die Anzeige des ausgewählten Menüeintrags, ganz so, […]

MEHR ERFAHREN

Wo ist der statische Inhalt?

In den Joomla! Versionen vor 1.5 wurden statische und dynamischen Inhalte unterschiedlich erstellt. Die Erstellungsprozesse wurden nun zusammengelegt. Beide Inhaltstypen sind noch vorhanden, werden aber nicht mehr getrennt behandelt. Wenn Sie statische Inhalte erstellen möchten, dann wählen Sie als Bereich und Kategorie l „Nicht kategorisiert„.

MEHR ERFAHREN

Meine MySQL-Datenbank unterstützt nicht utf-8. Habe ich ein Problem?

Nein, haben Sie nicht. Versionen von MySQL, die älter als Versionsnummer 4.1 sind, unterstützen kein utf-8. Joomla! 1.5 hat aber aus Abwärtskompatibilitätsgründen Vorkehrungen getroffen und kann utf-8 auch mit älteren Datenbanken verwenden. Lassen Sie das Installationskript alle Einstellungen vornehmen. Es ist deshalb nicht nötig, die Datenbank zu verändern (hinsichtlich des Zeichensatzes, der Kollation oder anderem).

MEHR ERFAHREN

Wozu dient die FTP-Ebene?

Die FTP-Ebene ermöglicht Datei-Operationen (wie die Installation von Erweiterungen oder die Aktualisierung der Hauptkonfiguration), ohne sämtliche Dateien und Verzeichnisse beschreibbar zu machen, was insbesondere bei Linux und anderen Unix-basierten Systemen hinsichtlich der Dateirechte ein Problem war. Das erleichtert dem Site-Administrator das Leben ungemein und erhöht die Sicherheit der Site. Sie können die Verzeichnisberechtigungen überprüfen, indem […]

MEHR ERFAHREN

Nur noch ein Fenster zur Bearbeitung! Wie erstelle ich den „Weiterlesen…“-Link?

Dies funktioniert nun durch Einfügen eines Tags (die entsprechende Schaltfläche befindet sich unter dem Editor-Bereich). Eine gestrichelte Linie erscheint im Text, um die Zeilenbruchstelle anzudeuten, wo der „Weiterlesen…“-Text sichtbar sein wird. Ein neues Plugin kümmert sich um den Rest. Es darf an dieser Stelle erwähnt werden, dass es keine negative Auswirkung auf migrierte Inhalte von […]

MEHR ERFAHREN

Funktioniert Joomla! 1.5 mit PHP Safe Mode On?

Ja, das geht! Das ist eine bedeutende Sicherheitsverbesserung. Der Safe Mode schränkt die Rechte von PHP-Dateien so ein, dass diese nur Funktionen mit Dateien/Verzeichnissen ausführen können, bei denen der Besitzer derselbe ist wie der PHP-Benutzer. Meistens ist dieser PHP-Benutzer Apache. Da Dateien meistens von Joomla! oder über den FTP-Zugang erstellt werden, ist es durch die […]

MEHR ERFAHREN

Was ist mit den Lokalisierungs-Einstellungen geschehen?

Diese sind jetzt in der Sprachdatei <lang>.xml in den Sprach-Metadaten-Einstellungen definiert. Wenn Sie Lokalisierungsprobleme haben, etwa bei der Datumsdarstellung, dann können Sie die Einträge im ‚locale‘-Tag überprüfen/ändern. Beachten Sie, dass Lokalisierungseinstellungen mehrfach gesetzt sein können und der Host normalerweise die erste gefundene Einstellung verwenden wird.

MEHR ERFAHREN

Warum nutzt Joomla! 1.5 utf-8-Zeichenkodierung?

Nun… wie wäre es, wenn Sie sich nie mehr mit dem Einstellen von Zeichenkodierungen herumschlagen müssten? Wollte Sie schon einmal verschiedene Sprachen auf einer Seite oder Website anzeigen und irgendetwas erschien immer als Kauderwelsch? Mit utf-8 (einer Variante von Unicode) können Glyphen (Zeichen) von nahezu allen Sprachen mit nur einer Zeichenkodierung dargestellt werden.

MEHR ERFAHREN

Copyright © nsu-team-moehnsen.de 2022 Webdesign by dh-creative-webdesign.de Impressum     Datenschutz